Temporary bookstore site outage
Incident Report for Argos Education
Resolved
This incident has been resolved.
Posted Jan 31, 2022 - 19:33 UTC
Investigating
We are currently investigating this issue.
Posted Jan 31, 2022 - 19:25 UTC
This incident affected: Argos Education Store.